A fix has been implemented and we are monitoring the situation.
Posted Jan 20, 2026 - 15:21 EET
Identified
We have identified an performance issue with the latest update. We will be implementing a fix shortly which might cause minor disruption. We apologize for this disruption.
Posted Jan 20, 2026 - 14:56 EET
This incident affected: System availability and Authentication.